


- Please be sure to read and understand Precautions and Introductions in CX-One Setup Manual, CX-Programmer 
Operation Manual and CX-Integrator Operation Manual before using the product.

- This Guide describes the basic operation procedure of CX-Programmer. Refer to the Help or the Operation Manual
of the PDF file for detailed descriptions.

- Acrobat Reader 5.0 or later is required to read the PDF files.

- You can display the PDF files from the  [Start] menu on your desktop after installing the CX-Programmer.

- The screen views used in this guide may be different from the actual view, and be subject to change without notice.

- The product names, service names, function names, and logos described in this guide are trademarks or 
registered trademarks of their respective companies. 

- The symbols (R) and TM are not marked with trademarks and registered trademarks in this guide respectively

- The product names of the other companies may be abbreviated in this guide.

Introduction
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CX-One is an FA Integrated Tool Package that integrates Support Software for OMRON's PLC and other 
Components.
To construct an FA System based mainly on PLC, traditionally it was necessary to purchase and install 
individual Support Software compatible with each Unit, start the software individually, and then connect 
to PLC and individual Components.
Installation of this FA Integrated Tool Package  "CX-One" on a personal computer allows integrated 
operation from setup of OMRON's CPU Bus Units and Special I/O Units (SIOU) and Components to 
network start-up/monitoring and improving efficiency of PLC System start-up.

1. What is CX-One?1. What is CX-One?

2. Features of CX-One2. Features of CX-One

CX-One allows integrated management of Support Software for OMRON's PLC/Components.

• Installation on only one personal computer allows a user to handle Support Software for OMRON's
products.

• Only one licensing key is required to install all Support Software.
• It allows integrated management of one save location for files created by Support Software.

Support Software dedicated to CPU Bus Units and Special I/O Units can be started on the I/O Table.

• The appropriate dedicated Support Software can be automatically started by specifying a 
registered Unit in the I/O Table (Unit configuration table attached to a PLC). In addition, setup 
information such as PLC model can be passed to the dedicated Support Software at start-up, 
allowing easier switching between Support Software.

The following functions are available by the introduction of the ID information file (CPS) for OMRON 
Components.

• Setup of CPU Bus Units and Special I/O Units without manual setting and address recognition.
(Parameter and selection item names as well as available range of setup are automatically 
displayed)

• CPU Bus Units and Special I/O Units setting on personal computer and data on actual PLC (CPU 
Unit ) can be verified online, and unmatched item/readout data is displayed graphically.

• Unit configuration is displayed on the I/O Table based on Unit model.
• Device type on the network can be checked for its Unit model, allowing exact verification of 

network configuration.

What is CPS?
CPS (Component and network Profile Sheet) is definition information of CS/CJ series Unit/Components in CX-One. 
It is provided as a CPS file (XML format file).
CX-One recognizes CS/CJ series Unit by information in this CPS file. CPU Bus Units and Special I/O Units setting 
is created based on this CPS file. 



3. Integrated Simulation3. Integrated Simulation

Provides an interoperability check between the ladder program and 
touch panel screens.

Operation can be verified before actual devices such as the PLC and PT (touch panel) are 
installed and wired, so software quality can be improved in the design stage.

Time can be saved by eliminating the tasks up to downloading the screen data from the 
computer to the PT. 

The operation of both the PLC and PT (touch panel) can be verified simultaneously in the 
computer, which greatly reduces the time required for debugging and equipment downtime 
during improvements.

Earlier Versions:
Operation checks had to be performed separately on the ladder program and PT (touch 
panel) screens. In addition, the program had to be downloaded to the devices.

Integrated Simulation is a function of CX-One (version 2.0 or higher) that 
simultaneously tests interoperability between the ladder program and PT 
(touch panel) and checks screen operation on the computer. 

Integrated Simulation Overview:

Using Integrated Simulation:

Simulation of the PLC – PT (touch panel) system can be started 
easily, with one click of an icon. 

CX-Programmer CX-Designer

One 
click

Linked and simulation started.

Ladder program Touch panel screen



Integrated Simulation Procedure

Use the following procedure to execute an integrated simulation of the ladder program and PT 
(touch panel) screen. For details, refer to the CX-Designer Operation Manual and CX-
Programmer Operation Manual.

2. Click the Icon or select Tools – Integrated Simulation. The PLC-PT Integrated Simulation 
Dialog Box will be displayed.

5. The test window will be displayed. 
The Test Tool Window will list all of the communications addresses being used in the displayed 
screen. For example, when “Host SERIAL A” is connected to the CX-Simulator, the CX-
Simulator value is reflected in the SERIAL A communications address. (The values can also be 
changed.) 

4. Click the Start Button. The PLC-PT Integrated Simulation will start automatically.

3. Click the Browse Button and select the desired ladder program (CXP) file. 

1. Create the screen data in the CX-Designer. 

Test Tool

Test Window



Before installing the CX-One, you must:
• Terminate all Windows programs
• Uninstall previous versions of Support Software (such as CX-Programmer) if already 

installed.
• Installation takes about 10 to 40 minutes depending on your personal computer. (10 

minutes for a personal computer with CPU: Celeron 2.2GHz, main memory: 512MB, and 
CD-ROM drive: 48x)

• To change/modify/delete CX-One after installation, refer to the PDF manual “CX-One 
Setup Manual”, Chapter 2 ”Installation and Uninstallation”.

Before installing the CX-One, you must:
• Terminate all Windows programs
• Uninstall previous versions of Support Software (such as CX-Programmer) if already 

installed.
• Installation takes about 10 to 40 minutes depending on your personal computer. (10 

minutes for a personal computer with CPU: Celeron 2.2GHz, main memory: 512MB, and 
CD-ROM drive: 48x)

• To change/modify/delete CX-One after installation, refer to the PDF manual “CX-One 
Setup Manual”, Chapter 2 ”Installation and Uninstallation”.

4. CX-One Installation Procedure4. CX-One Installation Procedure

Installing CX-OneInstalling CX-One

In case of the installing procedure by CD-ROM:
Insert CX-One installation disk 1 (CD-ROM) into your personal computer’s CD-ROM drive.
[Choose Setup Language] dialog box is displayed. By default the OS language installed on 
your personal computer is automatically selected.
Check if the language is appropriate, then click the [OK] button.

Click [OK]

The CX-One splash screen is displayed and CX-One installation starts.

Uninstall older version of tools such as PLC Tools (PLC System setting and I/O Table),
CX-Server, and CX-Programmer if they have been installed.

Uninstalling CX-Programmer Uninstalling CX-Server

Always click [OK]



Click [Next]

CX-One setup wizard starts.

The [License Agreement] dialog box is displayed.
Read the software license agreement carefully. If you agree with all items, select the [I accept 
the terms of the license agreement] radio button and click the [Next] button.

Select the radio button

The [User information] dialog box is displayed.

Enter [User], [Company], 
[License] (product serial 
number of CX-One)

Click [Next]

Click [Next]



The [Installation Folder Selection] dialog box and [Setup Type] dialog box are displayed.
Select an installation 
folder, then click [Next]

The [Program Folder Selection], [Choose Destination Location of OMRON FB Library], 
[Select Program Folder], and [Ready to Install the Program] dialog boxes are displayed.

Read the message and 
click [Next]

Click [Install]

CX-One installation is starts.

Insert CX-One Disks 2 and 3 
then click the [OK] button.

Click [Finish]

A dialog box (right) is displayed.
Click the [Finish] button to finish 
the installation wizard.
Installation is complete.
(When it is necessary to restart the 
personal computer, a restart 
confirmation dialog box appears.) 

Select the radio button 
[Complete]

Click [Next]

By selecting [Custom], you 
can individually select and 
install Support Software 
from the CD-ROM.



Online RegistrationOnline Registration

If the personal computer that the software has been installed on has an Internet connection, 
you can proceed to online user registration.

After installation has been completed the [Online Registration] dialog box is displayed.

If you click the [Register] button, your Web browser connects to “OMRON’s CX-One Web 
site”.(*1) (*2)

*1: If you click the [Exit] button to cancel online registration, the [Online Registration] dialog box 
is displayed every time the CX-One Support Software is started.

*2: If you do not have an Internet connection, or you do not want to register online, fill out and 
send the user registration card that comes with the product.





This chapter describes an example of PLC System construction from design, online debugging on the actual 
machine, and start-up/adjustment on-site as shown below.
CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, 
while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-
Simulator is used as a debugging example.

Example of PLC System Construction by CX-OneExample of PLC System Construction by CX-One

Reading 
Project

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

Project

Online 
Connection

to PLC

Transferring 
to Machine

Program 
Debug

Program 
Modification

Unit 
Parameter 

Change

System ConfigurationSystem Configuration

R88D-WN01L-ML2Servo Driver

CJ1W-SCU41-V1Serial Communications 
Unit 

Maximum control: 16 axis
Maximum control: 30 axis

CJ1W-NCF71
CJ1W-MCH71

Position Control Unit
Motion Control Unit

CJ1W-DRM21DeviceNet Master Unit

8 inches TFTNS8-TV00B-V1NS Series PT

CJ1W-CLK21ControllerLink Unit

4 analog inputs (Each point 
selectable from 1~5V, 0~5V, 
0~10V, -10~10V, 4~20mA)

CJ1W-AD081-V1Analog Input Unit

CJ1W-OC211Transistor Output Unit

CJ1W-ID211DC Input Unit

640 points, 20K stepsCJ1M-CPU13CPU Unit

CJ1W-PA202Power Unit

SpecificationsModelUnit Name

Workflow in This ChapterWorkflow in This Chapter

Below is an example of a System that has CJ1M CPU 
Unit with basic input/output Unit as well as analog input 
Unit and NCF Unit to perform the following functions:
• 4~20mA input from a sensor
• Configure a servo driver connected to the NFC Unit.

DesignDesign Online Debug of the MachineOnline Debug of the Machine Start-Up/Adjustment On-SiteStart-Up/Adjustment On-Site

CJ1W-AD081-V1
Unit No.= 21

CJ1W-CLK21-V1
Unit No.= 1Hex
Node Address= 01
Termination Resistance 
Setting= ON

CJ1W-DRM21
Unit No.= 0Hex
Node Address= 01

CJ1W-NCF71
(CJ1W-MCH71)

Unit No.= 2Hex

CJ1W-SCU41-V1
Unit No.= 3Hex

CJ1W-ID211

CJ1W-OC211

Servo Driver
R88D-WN01L-ML2

CJ Series PLC CJ1M

4 ~ 20mA

Sensor

Connection Cable
CS1W-CN226(2m)

CX-One

PLC1

NS Series PT
NS8-TV00B-V1
System Version 6.0 or later

Connection Cable
XW2Z-200T(2m)



Starting CX-ProgrammerStarting CX-Programmer

Click            .

Left-click

Select a PLC model from the following to use Function Blocks.
CJ2H, CS1G-H, CS1H-H, CJ1G-H, CJ1H-H, CJ1M

Click this button to create a new CX-Programmer project.

Click         and select 
PLC model.

Click        and select CPU type.

Click [OK] and 
determine CPU type.

From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-
Programmer] to start CX-Programmer. (Or select [All Programs] > [OMRON] > [CX-One] > 
[CX-Programmer] > [CX-Programmer])Starting CX-Programmer

Creating a New Project

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a ProjectDesign

Dedicated Support Software for each Unit can be 
started, succeeding communications settings from 
CX-Programmer. You will not have to set up 
communications using dedicated Support Software 
if you set up communications here.



Creating Unit ConfigurationCreating Unit Configuration

Start the I/O Table/Unit setup function.

Right-click Empty Slot, select [Add Unit] and determine CPU type.
Then select [General Purpose Analog I/O] from Unit selection window.

Double-click [ I/O Table 
and Unit Setup]

Right-click

Click + symbol on 
analog I/O

Select [Add Unit]

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

When you select [Option] > [Consumption(mA)] from the 
menu, you can check the width and current consumption 
after PLC Unit configuration.
(Width indication is available only for SYSMAC CJ Series)

Double-click [ I/O 
Table and Unit Setup].

Design



Click

Enter Unit number.

Select Unit and Number.

Select Unit Type.

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Click

Design



Double-click the analog 
Unit

The Analog Unit is registered to the I/O Table as shown below.
Set up the next analog Unit’s parameter.

The Analog Unit Setup Screen is displayed.

CPU Bus Units and Special I/O Units Setting 
Function
Traditionally, initial CPU Bus Unit and Special 
I/O Unit settings were made by referring to 
documentation to calculate DM address from 
the Unit number and entering a hexadecimal 
number. Now you can set it using the pull-down 
menu in the CX-Programmer’s I/O Table.
Easy setup/transfer/verification operations are 
available from the integrated parameter settings 
screen as shown below, without recognizing 
addresses (this function uses CPS function of 
CX-One previously described).

For example, specify input number designation and range.

Unit parameter setting

Setting CPU Bus Units and Special I/O UnitsSetting CPU Bus Units and Special I/O Units

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Select [Enable] for input No.1 usage designation.

Select [1~5V/4~20mA] for input No.1 range setting.

Click the [OK] button.

Design



Right-click NCF Unit

As with Analog Unit registration, register the NCF Unit (CJ1W-NCF71).
The NCF Unit resides within a position control Unit.
Nest, start CX-Motion-NCF using [Start with Settings Inherited].

Register a servo driver.

NCF Unit and Servo Driver Connected to the NCF Unit SetupNCF Unit and Servo Driver Connected to the NCF Unit Setup

Point [Start Special 
Application]

Click [Start with 
Settings Inherited]

Double-click NCF Unit

Click

Double-click NCF Unit.
Click 

Displayed with NCF Unit registered.

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving a 

Project

Click

Select OMRON W series (with 
communications function).

Select R88D-WN01L-ML2.

When opening a stored project file after starting the dedicated tool, select [Start Only].
If [Start with Setting Inherited] is selected, a new project is created.

Design



Double-click NCF Unit

Edit NCF Unit parameters.

Edit servo parameters.

Double-click the servo 
driver

Click

Set output relay area to 
CIO100 and input relay 
area to CIO500.

Select
[Communications Setting]

Select [Axis 01].

Set servo parameters for axis 01 as shown below.
Pn50A(input signal selection 1): 2881
Pn50B(input signal selection 2): 8883
Pn511(input signal selection 5): 6541

Click

Set axis parameters 
for axis 01.

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Click

Double-click NCF Unit.

Save the project Refer to Page 2-13 “Saving Project” for details.

Design



Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Right-click MCH Unit

When using the MCH Unit (CJ1W-MCH71) instead of the NCF Unit, use the following settings.

As with Analog Unit, register the MC Unit to the I/O table.
The MCH resides within the Motion Controller.
Then start CX-Motion-MCH using [Start with Settings Inherited].

Using the MCH UnitUsing the MCH Unit

Point [Start Special 
Application]

Select [Start with 
Setting Inherited]

Add task, axis, program, 
and CAM data

Start the MCH Unit as registered.

When opening a stored project file after starting the dedicated tool, select [Start Only].
If [Start with Setting Inherited] is selected, a new project is created.

Click to add task, axis,

program, and CAM data.

Open the editing screen to edit data by double-clicking 
position data, parameter, program, or CAM data on the 
project tree.

Edit position data, 
parameters, program, 
and CAM data

Save the project
Click          and save the project to file.

Design



Register basic I/O Unit

Check I/O assignment

Checking I/O AssignmentChecking I/O Assignment

As with Analog Unit registration, register the IN and OUT Units.

In this example, CJ1W-ID211 
and CJ1W-OD211 are selected 
as IN and OUT Units respectively.

By registering Units to the I/O Table, you can check I/O assignment status.

This I/O assignment information can also be checked by IQ indication (IN:I, OUT:Q) during 
ladder programming.

In addition, you can check addresses 
assigned to actual I/O with a print out.

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a ProjectDesign



ProgrammingProgramming
This section describes programming with Library (OMRON Standard Libraries) that allows 
easier connection to OMRON’s Components. OMRON Standard Libraries is a group of 
Components provided by OMRON, which can be categorized into two types; FB Components 
(OMRON FB Library) to be used for a ladder program and SAP Components (Smart Active 
Parts Library) to be used for an indicator.

NCF Unit Programming with OMRON FB Library
Servo motor (axis 1) connected to Unit number 0 NCF is moved to position 2000 
(command Unit) with speed of 2000 (command Unit/s) by relative move command.

Right-click from Function 
Blocks

Select OMRON FB Library 
"_NCF021_MoveRelative_
DINT11.cxf"

Select a folder from 
[Omronlib] > [Position 
Controller] > [NCF]

Paste the selected OMRON FB Library on the ladder, then enter its name (instance name) 
(in this example, “MoveRelative”). Then create a ladder program as shown below.

Enter “MoveRelative” for 
instance name. Then 
create a ladder program

OMRON FB Library is a collection of Components that OMRON provides as a Function Block 
to use functions of OMRON’s Units for PLC and FA Components much easier on a PLC 
program. * For details, see FunctionBlock StructuredText Introduction Guide, Chapter 1.

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

 

Servo Motor No.1 
(Axis 1) 

NCFCPU 

Servo Motor 
(Axis 1) 

Unit No.: 0&0

Unit No.
&0

Axis No.
Axis 1 → &1

Start No.2
W10.02

Position Command
2000 Command Unit → &2000

Velocity Command
 

2000 Command Unit/s → &2000  
 

 
 
Positioning is completed 
W10.03 
Command is aborted 
W10.04 
Error Flag 
W10.05 
 
(Omitted) 

 

P_On (Normally ON) _NCF021_MoveRelative_DINT 
EN 
(BOOL) 

(BOOL)
ENO

UnitNo 
(INT) 

(BOOL)
Done

Axis 
(INT) 

(BOOL)
Command Aborted

Execute 
(BOOL) 

(BOOL)
Error

Position 
(DINT) 

(WORD)
ErrorID

Velocity 
(DINT) 
 

ENO

W10.00 
 

Start Trigger
W10.02 

 
Start No.2 

W10.02 
 
 

Start No.2 

W10.01 
 

(ENO) 

W10.03 
 

Done 

W10.05 
 

Error 

W10.04 
 

Command 
Aborted 

Design



Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

How to use Smart Active PartsHow to use Smart Active Parts

This section describes how to use Smart Active Parts. In this example, NCF Smart Active Parts 
“Adjust Operation” is used.

See LibrarySee Library

Place Smart Active 
Parts on the screen.
Place Smart Active 
Parts on the screen.

Select [Library] from the 
[Tools] menu

4. The selected Smart Active Parts are   
displayed on the screen.

Setup Smart Active 
Parts

Setup Smart Active 
Parts

1. Double-click

2. Set 4 to the Destination 
Unit No.

3. Click [OK]

Smart Active Parts 
Setting is complete
Smart Active Parts 
Setting is complete

4. Communication address is 
automatically calculated according 
to the corresponding Unit.

Setup is completed at 
100% 

1. Select SmartActiveParts_E
-Motion - NCF -
OutCIO_InCIO folder

2. Select _NCF001_xx
_Adjust Operation 
(Check the Title)

3. Drag & drop it on the screen.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer 
Ver. ] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > 
[CX-Designer Ver. ].) Select [NS8-TV0[]-V1] and [System Version 6.0] or later.

Refer to Page 2-13 “Saving Project” for details.Save the Project.Save the Project.

Design



Offline DebugOffline Debug

This section describes how to debug a program using CX-Simulator, a ladder simulation tool, 
without the PLC.
Additionally, Switch Box Utility is used as a virtual input tool.

Click [OK]

Click [OK]

Click

Program transfer starts.

Screen when online

(Simulator connection button)

Switch Box Utility
It is useful not only for virtual input by simulator but also for debugging 
while checking the PLC’s wiring or setting the DM and other initial values.

Starting Switch Box Utility
Select [Tools] > 
[SwitchBox Utility]

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Run PLC

CX-Simulator debug 
console is starts

Design



Saving a ProjectSaving a Project

Unit setting, Unit parameter setting, and programs using the CX-Programmer can be saved all 
at once.

Save it with a name. In this example save as “Sample1”.

Saving a CX-Programmer file

Saving CX-Designer and 
CX-Motion-NCF/MCH files

Created data can be saved for CX-Designer and CX-Motion-NCF/MCH.
Save CX-Motion-NCF as “Sample2.mnf” (CX-Motion-MCH as “Sample5.mnh”), and CX-
Designer as “Sample3.ipp”. 

Saving screen for CX-Motion-NCF Saving screen for CX-Designer

Starting CX-
Programmer

Creating Unit 
Configuration

Checking I/O 
Assignment

Setting 
CPU Bus 

Units/SIOU
Programming Offline Debug Saving 

a Project

Click

If you run a dedicated Support Software such as CX-Motion-NCF or CX-Designer when CX-
Programmer is started, the same default folder location as that of CX-Programmer is used for 
reading and saving files. It allows easier CX-One Support Software file management.

If you run a dedicated Support Software such as CX-Motion-NCF or CX-Designer when CX-
Programmer is started, the same default folder location as that of CX-Programmer is used for 
reading and saving files. It allows easier CX-One Support Software file management.

From the [File] menu, 
select [Save As…]

Design



Reading a ProjectReading a Project

Use CX-Programmer to read the project “Sample1” saved in the previous section.

Ladder program “Sample1” is retrieved.

Reading a 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Online Debug on 
a Machine

This section describes connection to the machine, transfer of programs, creating Unit settings 
offline, and how to debug.

From [File] > [Open], select 
the file name “Sample1”

In I/O Table Unit setting function, the Unit parameter setting configured in the previous 
section is also retrieved.

Double-click the I/O 
Table Unit setting

Click

or



Online Connection to PLCOnline Connection to PLC

(Automatic online 
connection button)

Verify that PLC model and communications setting created offline and the actual PLC are 
correct.

(Online connection button)

Double-click PLC

Check PLC model. Check communications setting.

Click

Reading a 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Confirm that automatic 
communication speed recognition 
is checked.

Confirm that automatic 
communication speed recognition 
is checked.

If a connection cannot be established with the PLC, 
you can use the automatic online connection 
function.
Save your current project data before using this 
function because it clears project data being edited.
When USB conversion cable (CS1W-CIF31) is used 
for connection, specify the COM port number of the 
USB port used.

If a connection cannot be established with the PLC, 
you can use the automatic online connection 
function.
Save your current project data before using this 
function because it clears project data being edited.
When USB conversion cable (CS1W-CIF31) is used 
for connection, specify the COM port number of the 
USB port used.

Online Debug on 
a Machine



Click [Transfer All]

Program transfer starts.

Transferring to the MachineTransferring to the Machine

Click [OK].

Select [PLC] > [Transfer] 
> [To PLC]

Transfer programs and Unit setting parameters created by offline project to the PLC.
In this example, data is sent at the same time to various Units using the batch transfer function.
[Data to be sent]
CPU Unit: Ladder program and PLC System setting data, I/O Table data
CPU Bus Units and Special I/O Units:

AD Unit: Range setting of inputs (1~5v / 4~20mA mode)

Program and configuration data 
are transferred at the same time 
to CPU Bus Units and Special 
I/O Units.

Program and configuration data 
are transferred at the same time 
to CPU Bus Units and Special 
I/O Units.

Reading a 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Online Debug on 
a Machine

Next Page

Click [Yes].

CJ1W-AD081-V1
Unit No.= 21

CJ1W-CLK21-V1
Unit No.= 1Hex
Node Address= 01
Termination Resistance 
Setting= ON

CJ1W-DRM21
Unit No.= 0Hex
Node Address= 01

CJ1W-NCF71
(CJ1W-MCH71)

Unit No.= 2Hex

CJ1W-SCU41-V1
Unit No.= 3Hex

CJ1W-ID211

CJ1W-OC211

Servo Driver
R88D-WN01L-ML2

CJ Series PLC CJ1M

4 ~ 20mA

Sensor

Connection Cable
CS1W-CN226(2m)

CX-One

PLC1

NS Series PT
NS8-TV00B-V1
System Version 6.0 or later

Connection Cable
XW2Z-200T(2m)



Then data is sent at the same time to NCF Unit and the servo driver connected to NCF Unit.

[Data to be sent]
NCF Unit: Common parameters, axis parameters
Servo Driver: Servo parameters

Right-click NCF Unit

Point [Start Special 
Application]

Click [Start Only]

From CX-Programmer, display the I/O Table, 
then start CX-Motion-NCF by [Start Only].

Open a saved project and transfer all NCF Unit and servo driver parameters.

Click

Select “Sample2.mnf”

Double-click NCF Unit

Double-click NCF Unit.

If it does not go online, click 
and check the communications 
setting between the personal 
computer and PLC.

Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Online Debug on 
a Machine

To prevent a servo driver operation using a ladder 
program, you must set the PLC to PROGRAM mode.

Click

Click



Next, perform jog operation. Carefully read the displayed cautions, then perform the operation.
To perform jog operation, it is required to establish a connection, servo lock, and jog setting.

When parameter transfer is completed, confirm that communications is performed normally and 
has not resulted in an error.
Monitor the NCF Unit. Confirm consistent scan list (axis configuration) and communications 
status and that no axis or common Unit error has resulted.

Click

Click

Click [Online] > [Test Run]

Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] 
button after confirming safety. Also, in the case of communication was not established 
between the  NCF Unit and the servo driver, confirm the axis number and restore power to 
the NCF Unit and servo driver.

Terminate 
Unit monitoring.

Online Debug on 
a Machine



Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Online Debug on 
a Machine

When using the MCH Unit, transfer data from the CX-Motion-MCH to the MCH Unit and servo 
driver connected to the MCH Unit.
[Data to be transferred]
MCH Unit: parameter, position data, program, CAM data.
Servo driver: servo parameter

Display the I/O table from CX-Programmer and start CX-Motion-MCH with [Start Only]. 
(Refer to NCF Unit for starting from the I/O table.)

Select file .mnh

Select [All Data]

Click [Open]

If it does not go online, double-
click PLC in the project tree and 
check the communication 
settings between the personal 
computer and PLC.

To prevent a servo driver operation using a ladder program, you must set the 
PLC to PROGRAM mode.

Select [With Servo 
Parameter]

Click [OK]

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button 
after confirming safety. Also, in the case of communication was not established between the 
MCH Unit and the servo driver, confirm the axis number and restore power to the MCH Unit 
and servo driver.

Open the saved project and transfer Unit parameter, position data, program, CAM data, and 
servo driver parameters to the MCH Unit.

Click

Click

Click



Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Online Debug on 
a Machine

Transferring NS screen dataTransferring NS screen data
This section describes how to transfer screen data to the NS through PLC without changing 
cables.Start NS transfer 

program
Start NS transfer 
program

Check “Pass thru PLC”
in the Comm. Method 
window

Check “Pass thru PLC” to activate 
the “PC PLC NS” route setting.

Select PC – PLC – NS.

Select Serial(Toolbus)

Select NT Link
Press each setting button.

Set the serial port 
COM No. for PC 

PLC connection.
Then, press OK.

Enter NS Unit No. 
Then, press OK.

Setup “Data transfer to 
the NS through PLC”.

Click OK to start transfer

Setup 
communication route
Setup 
communication route

Transfer screen dataTransfer screen data

Screen data transfer is 
complete at 100%.
Screen data transfer is 
complete at 100%.

*Communication between the NS and the PLC 
must be established before transferring screen 
data through PLC without changing cables.

If “Connecting…” is displayed at the right bottom 
of the screen, use Auto Connection (See Chapter 
3 1-3  “Setup NT Link”) to connect the NS and the 
PLC before starting the following procedure.

If the communication between the NS and the 
PLC has already been established, you do not 
need to perform the operation described above.

Click on

Select [Transfer]-[Transfer[To PT…]] from the [PT] menu.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer 
Ver. ] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > 
[CX-Designer Ver. ].) Open a project  saved in the previous section.



Frame color changes to 
a specified color during 
Function Block execution.

Frame color changes to 
a specified color during 
Function Block execution.

Current parameter 
value is displayed.
Current parameter 
value is displayed.

Program DebugProgram Debug

Transfer programs and Unit setting parameters created by an offline project to the PLC.
In this example, data is sent at the same time to various Units using the batch transfer function.

Online Debug on 
a Machine

Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Monitoring

Monitor ON/OFF status of contacts and coils.

Click

Click [Yes]

. . . ON/OFF of monitoring



Change current value of the input parameter.

Ensure to add  "#" (hexadecimal/BCD) 
or  "&" (decimal) to the left of the value.

Click

Online Debug on 
a Machine

Reading 
Project

Online 
Connection 

to PLC

Transferring 
to a 

Machine
Program 
Debug

Monitoring -2 Changing the Current Parameter ValueMonitoring -2 Changing the Current Parameter Value

Change the current value of contact or channel through conductive monitoring.

Move the cursor to D100 
of input parameters

Right-click, then select 
[Set/Reset (S)] > [Value 
(V)] from the pull-down 
menu

or

ENT

Or

Double-click



Select [Program] > 
[Online Edit] > [Start]

Enter the contact number you want to modify (W20.01 in a circuit example).

Select [Program] > 
[Online Edit] > [Transfer 
Change]

Double-clickDouble-click

Start-Up / 
Adjustment On-

site

Program 
Modification

Unit 
Parameter 

Change

Online Program Modification (Online Edit)Online Program Modification (Online Edit)

Move the cursor on the 
circuit you want to modify

You can use drag-and-
drop to specify more than 
one circuit at the same 
time

Shortcut [Ctrl]+[E]

Move the cursor on the 
contact you want to modify 
and double-click

Shortcut
[Ctrl]+[Shift]+[E]



Start-Up / 
Adjustment On-

site
Program 

Modification

Unit 
Parameter 

Change

After modification on-site, you can verify it with the designed program and display the 
differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”.
Then connect online.

2. Select verification.

3. Display the verification result.

Verifying ProgramVerifying Program

Select [PLC] > [Transfer] 
> [Compare with PLC]

Click [OK]

(Online connection button)

Click

Click [OK]

Click [Section (1)] > 
[Mnemonic View]

You can check ladder contact 
address differences.

You can check ladder contact 
address differences.

You can check FB parameter 
differences.

You can check FB parameter 
differences.

In addition, you can check add, 
delete, and move contacts, coils, and 
apply instructions.

In addition, you can check add, 
delete, and move contacts, coils, and 
apply instructions.



Start-Up / 
Adjustment On-

site
Program 

Modification
Unit 

Parameter 
Change

After modification on-site, you can verify it with the designed Unit parameter and display the 
differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”.
Then connect online. (If you have already read it in the previous section’s operation, this is not 
required)
Open the I/O Table/ Unit setting, then double-click the AD Unit.

Unit Parameter Change and VerificationUnit Parameter Change and Verification

Click [I/O Table/Unit 
Setting]

Double-click the 
registered AD Unit

Click [Compare] button

Click

2. Click the [Compare] button.
Now you can see the difference between the designed Unit parameters and the configured 
parameters in the machine.

You have now completed Chapter 2: Example of PLC System ConstrucYou have now completed Chapter 2: Example of PLC System Construction by CXtion by CX--One.One.
The next chapter describes PLC network construction flow.The next chapter describes PLC network construction flow.

3. Unmatched detail differences can also be checked.

You can check the 
number of unmatched 
items.

You can check the 
number of unmatched 
items.

Unmatched items are 
shown in orange.

Unmatched items are 
shown in orange.

After checking the 
unmatched details, Unit 
parameters can be easily 
modified.

After checking the 
unmatched details, Unit 
parameters can be easily 
modified.





System ConfigurationSystem Configuration

Servo Driver
R88D-WN01L-ML2

CJ1W-CLK21-V1
Unit No. =1Hex
Node Address =03
Termination Resistance 

Setting =ON

Connection Cable
XW2Z-200T

(2m)

CX-One

PLC1
CJ Series PLC CJ1M-CPU13

CJ1W-CLK21-V1
Unit No. =1Hex
Node Address =02
Termination Resistance  Setting =OFF

PLC2
CJ1G- CPU45H

PLC3
CJ1G- CPU45H

CJ1W-CLK21-V1
Unit No. =1Hex
Node Address =01
Termination Resistance Setting =OFF

CJ1W-DRM21
Unit No. =0Hex
Node Address =01
Other Settings = Default

CJ1W-SCU41-V1
Unit No. =3Hex

CJ1W-DRM21
Unit No. =0Hex
Node Address =05

CJ1W-DRM21
Unit No. =0Hex
Node Address =04

CJ1W-ID211

CJ1W-AD081-V1
Unit No. =21

CJ1W-NCF71
Unit No. =2Hex

NS Series PT
NS8-TV00B-V1
System Version
6.0 or later

E5CN-CQ203T-FLK
Unit No. =1

E5CN-CQ203T-FLK
Unit No. =2CompoWay/F Network

Connection Cable
CS1W-CN226

(2m)

Routing Table (Local Network Table )

Note) The Local Network Table is required in order to 
attach more than one network communications Units.

CJ1W-OC211

Setting

Unit No. Network 
Address

1 1
2 2

Controller Link (Wire) Network Address =1

DeviceNet Network 
Address = 4

Use at 125K bits/sec

I/O Relay 
Terminal

I/O Relay 
Terminal

CJ1W-CRM21

DeviceNet Network 
Address = 3

DeviceNet Network 
Address = 2 I/O Relay 

Terminal
I/O Relay 
Terminal

I/O Relay 
Terminal

I/O Relay 
Terminal

Use at 125K bits/sec

Use at 125K bits/sec
CompoNet Network Communications Mode No. 1

Word Slave Word Slave

Example of PLC Network System Construction by CX-OneExample of PLC Network System Construction by CX-One

Workflow in This ChapterWorkflow in This Chapter

This chapter describes an example of PLC network System construction from start-up to reassembly and on-site 
adjustment as shown below.
This chapter mainly describes how to start up the System using CX-Integrator, an integrated start-up Support 
Software for various PLC networks.

Start-Up
• Describes details from assembly and wiring of PLC 

System to program download for a trial run.
• Target of Start-Up

Aims at removing the cause of errors from a PLC 
and to turn off all of red LEDs that indicate errors for 
any component of the PLC System.

• Saving the entire system configuration after 
completing start-up is recommended. You can utilize 
it for system adjustment on-site after delivery to 
reduce the adjustment period.

Adj. On-site
• Describes details from disassembly of a system for which 

the trial run, delivery, and reassembly on-site as well as 
operation check have been completed.

• Target of Adjustment On-site
1) Confirm that no error will occur in its electrical system in
the same system configuration as that before delivery.

2) Confirm that no discrepancy will be found in Controller 
Link network settings by connecting to a network on-site.

3) Though CompoNet network is characterized by tool-less 
easy start-up, using the tool can shorten the time required to 
check the wiring.

Start-Up Delivery Adj. On-site

PLC 
Start-Up

NT Link 
Start-Up

DeviceNet 
Start-Up

Controller 
Link 

Start-Up

CompoWa
y

/F Start-Up

System 
Config. 

Verification

Controller 
Link 

Diagnosis

Equipment 
Disass’y / 
Reass’y

Saving 
System 
Config.

Checking 
CompoNet

Network



Select a serial port.
When USB conversion 
cable (CS1W-CIF31) is 
used for connection, 
specify the COM port 
number of the USB 
port used.

All communications Units and ports of 
a connected PLC are automatically 
displayed in the online connection 
information window.

NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
Config. 

Verification

Controller 
Link 

Diagnosis

Equipment 
Disass’y / 
Reass’y

CompoWay
/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up

PLC Network Start-UpPLC Network Start-Up

Online Connection to PLC (Automatic Online Connection)Online Connection to PLC (Automatic Online Connection)

1. From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Integrator] > [CX-
Integrator] to start CX-Integrator. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-
Integrator] > [CX-Integrator])

CX-Integrator starts and automatically connects online.

(Important)
This operation is used for online 
connection to any PLC hereinafter. 
Unless described otherwise, use 
this operation to connect online.

(Important)
This operation is used for online 
connection to any PLC hereinafter. 
Unless described otherwise, use 
this operation to connect online.

Starting CX-Integrator

Click

Select a serial port, 
then click [Connect]



Checking PLC ErrorChecking PLC Error

NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
Config. 

Verification

Controller 
Link 

Diagnosis

Equipment 
Disass’y / 
Reass’y

CompoWay
/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up

Move the cursor on the 
PLC and right-click

(1) Remove the cause of the PLC error, then make it available to run.

Select [Error Log]

(2) Check the PLC error.
Examples of IO settings error and CPU Bus Units and Special I/O Units number overlap error 
are shown below.

You can check an error in a CPU 
Unit and error history.
(You can use the same function in 
the error history of CX-Programmer’s 
online screen)

You can check an error in a CPU 
Unit and error history.
(You can use the same function in 
the error history of CX-Programmer’s 
online screen)

(3) Solve the cause of error.

You must solve the problem through the following procedure:
- Set the PLC to PROGRAM mode (in which you can change settings).
- Change the rotary switch of the CPU Bus Units and Special I/O Units (make sure 

that it does not overlap).
- Create the I/O Table.

You must solve the problem through the following procedure:
- Set the PLC to PROGRAM mode (in which you can change settings).
- Change the rotary switch of the CPU Bus Units and Special I/O Units (make sure 

that it does not overlap).
- Create the I/O Table.

• Set the PLC to PROGRAM mode.
From step (1) above, select [Mode Setting] then [Program] mode, and click the [Set] button.

Click [Yes].



The I/O Table is created and 
Unit configuration is displayed.

The I/O Table is created and 
Unit configuration is displayed.

NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
Config. 

Verification

Controller 
Link 

Diagnosis

Equipment 
Disass’y / 
Reass’y

CompoWay
/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up

• To change the Unit number, change the rotary switch of CPU Bus Units and Special I/O Units 
and restart power.

• Create the I/O Table.

• Check if any error occurs in the PLC (CPU Bus Units and Special I/O Units number overlap 
error should be solved).

Click [Yes].

• Check if any error occurs in the PLC 
(all errors should be solved).



NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
Config. 

Verification

Controller 
Link 

Diagnosis

Equipment 
Disass’y / 
Reass’y

CompoWay
/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up

Confirming the Routing Table is not ConfiguredConfirming the Routing Table is not Configured

(1) Check that Routing Table is not configured.

Check Routing Table 
presence. If the Routing Table 
is not configured, create one.

Check Routing Table 
presence. If the Routing Table 
is not configured, create one.

Select 
[Start Routing Table]

Move the cursor on the 
PLC and right-click

Re-connect to a PLC 
with CX-Integrator

(2) Configure the Routing Table.

(3) Edit the Routing Table and transfer to [PLC].Right-click and select local 
network (Unit) [Insert CPU 
SIOU] or local network (port) 
[Insert  PORT]

Enter its local network 
number, then click [OK]

Reconnecting CX-Integrator

Set the Routing Table as shown below: 
• Assign a network number to a Unit number.
• A Unit number can be checked on the online information window.
• Assign a network number to each network.
The Controller Link network number is same for other PLCs.

Set the Routing Table as shown below: 
• Assign a network number to a Unit number.
• A Unit number can be checked on the online information window.
• Assign a network number to each network.
The Controller Link network number is same for other PLCs.

(4) Check if the error is solved.
• Re-connect to the PLC.
• All errors should be solved and no error messages should be displayed.
• The network number is displayed on the communications Unit.



DeviceNet Start-UpDeviceNet Start-Up

Remove DeviceNet communications errors and establish communications.
⇒ Check DeviceNet Unit’s 7SEG indication and ON state of MS/NS LED.
⇒ Check Slave Unit configuration trough CX-Integrator.

Create a scan list of DeviceNet and determine the memory map.

Remove DeviceNet communications errors and establish communications.
⇒ Check DeviceNet Unit’s 7SEG indication and ON state of MS/NS LED.
⇒ Check Slave Unit configuration trough CX-Integrator.

Create a scan list of DeviceNet and determine the memory map.

(1) Connect to PLC online, then connect to DeviceNet through the online connection information 
window.Right-click a DeviceNet 

Unit under Target Device 
in the online connection 
information window, then 
select [Connect]

(2) Next, upload the network configuration information of DeviceNet.

(3) After transfer is confirmed, connected devices on the current DeviceNet network are 
displayed as shown below.

In this example, although one Master Unit (node number #01) and two Slave Units 
(node number #02, #03) are actually connected, assume in this start-up example that 
one Slave Unit (#03) is not connected due to disconnection.

Check if a Slave device on the remote I/O 
communications actually wired is 
recognized. Master Unit (#01) and Slave 
Unit (#02) are recognized, while another 
Slave Unit (03) is not recognized.

NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
Config. 

Verification

Controller 
Link 
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Equipment 
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Reass’y

CompoWay
/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up



Right-click on the Master 
Unit icon and select 
[Monitor] to display the 
device monitor screen. 
Select [Status] tab

(4) Check the error on the device monitor screen.

You can check the Slave status on 
the device monitor screen as well.

Slave Unit (#02) is recognized, while the 
other Slave Unit (03) is not recognized.

(5) Wire Slave Unit (#03) correctly.

(6) Re-upload the network configuration information of DeviceNet.

Perform the step (2) from 
the previous page Now it can be confirmed that Slave 

devices on the remote I/O 
communications have been recognized 
and communications have been 
established.

(7) Configure DeviceNet remote I/O communications (free assignment) and register the Slave 
to the Master.Double-click a Master Unit 

(CJ1W-DRM21) icon

Click twice

Click the [OK] button

Two Slaves are now registered to the 
Master.

(8) Configure assignment of Slaves to areas of a CPU Unit.
If necessary, configure the Slave parameters as well.

<Master Unit parameter edit dialog box>

(9) Start remote I/O communication.

Right-click the Master Unit 
and select [Parameters] > 
[Edit]

Select [Network] > 
[Transfer [PC to Network]]

Edit the parameters, then 
click the [OK] button

NT Link 
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Link 

Start-Up

PLC Network 
Start-Up

Saving 
System 
Config.

System 
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/F Start-Up

PLC 
Start-Up

DeviceNet 
Start-Up



NT Link Start-UpNT Link Start-Up

Remove NT Link communication errors and establish communications.
⇒ Release NS Connecting . . . message.
⇒ Check NS configuration through CX-Integrator.

Remove NT Link communication errors and establish communications.
⇒ Release NS Connecting . . . message.
⇒ Check NS configuration through CX-Integrator.

(1) Connect to PLC online, then connect to a CPU Unit through the online connection 
information window.

(2) Select in the order from upper link port to NT link.

Right-click a CPU Unit 
under a connection target 
PLC in the online 
connection information 
window, then select 
[Connect]

(3) Next, select [NT Link Tool] > [NTLink Auto Online Setting] from the CPU Unit.

Automatic NT Link connection function is used to automatically connect NS series PT 
and PLC via serial connection (NT Link). Connection is automatically performed by 
overwriting the PLC serial communication port settings by adjusting to NS series PT 
settings.
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Click [OK]

Click [Yes]

Click [OK]

(5) Screen message Connecting . . . is now cleared.

(4) Check the CPU DIP switch.
• Follow the on screen instructions to change the DIP switch.

(6) Next, upload the network configuration information of NT Link.

(7) After the transfer is confirmed, connected devices on the current NT Link network are 
displayed as shown below.

Select 
[Transfer [Network to PC]]

NT Link 
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Start-Up



Controller Link Start-UpController Link Start-Up

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection 
information window.

Remove Controller Link communications errors and establish communications.
⇒ ON state of Controller Link Master Unit’s INS LED
⇒ Check Controller Link configuration through CX-Integrator.

Remove Controller Link communications errors and establish communications.
⇒ ON state of Controller Link Master Unit’s INS LED
⇒ Check Controller Link configuration through CX-Integrator.

(2) Next, upload the Controller Link network configuration information.

Right-click a Controller 
Link Unit in the online 
connection information 
window, then select 
[Connect]

Select 
[Transfer [Network to PC]]

Click [Transfer]

NT Link 
Start-Up

Controller 
Link 

Start-Up

PLC Network 
Start-Up
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Click [Transfer]

Select 
[Transfer [Network to PC]]

In this example, although three PLCs are actually connected through the Controller Link, 
in this start-up example explanation assume that only two PLCs are displayed.
(One PLC did not join the communications due to incorrect Routing Table settings)

(3) After the transfer is confirmed, connected devices on the current Controller Link network are 
displayed as shown below.

(4) Check the Routing Table and configure it correctly.
See “Confirming the Routing Table is not Configured” for configuration details.

(5) Re-upload the Controller Link network configuration information.

(6) Send the network configuration from the network to the personal computer.
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Saving 
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This example explains the start-up of a serial communications Unit with two temperature 
controllers (E5CN) connected via CompoWay/F.
• Two temperature controllers (E5CN) are connected to serial communications Unit

(CS1W-SCU41-V1) port no. 1 via RS485. Communication Unit numbers are #001 and #002.
• Communication settings of the serial communications Unit and the two temperature controllers are 
unmatched.
• Communication settings between the two temperature controllers are unmatched as well.

CompoWay/F Start-UpCompoWay/F Start-Up

Remove CompoWay/F communications errors and establish communications.
⇒ Check CompoWay/F configuration through CX-Integrator.
⇒ Configure serial communications Unit parameters.
⇒ Configure temperature controller communications.

Remove CompoWay/F communications errors and establish communications.
⇒ Check CompoWay/F configuration through CX-Integrator.
⇒ Configure serial communications Unit parameters.
⇒ Configure temperature controller communications.

(1) Connect to PLC online, then connect to a CPU Unit through the online connection 
information window.

Right-click an SCU port in 
the online connection 
information window, then 
select [Connect]

Click
(2) Upload the CompoWay/F network configuration information.

Select SCU port (140)

Select CompoWay/F

Click
Click

Select [Selection], enter 
1 for minimum and 2 for 
maximum values, then 
click the [OK] button

Right-click an SCU port in 
the online connection 
information window, then 
select [Transfer [Network 
to PC]]

Click [Yes] in the message 
dialog box

Click
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Click [OK]

Click the reset button to 
enable settings. Click [OK] 
in the reset confirmation 
message dialog box.

(1) (2)

(3)

This dialog box is displayed because communication is 
not established between the serial communications 
Unit and temperature controllers.

Then click the [OK] button 
in the dialog box indicating 
completion of transmission

(3) Adjust the serial communications board parameters settings to those of the CompoWay/F.
Place the cursor on CJ1M-
CPU in the [Network 
Structure] window and 
double-click

The [Network Structure] window 
shows a CPU Unit (CJ1M-CPU13) 
that has a serial communications 
Unit, but neither of the two 
temperature controllers.

From the menu, select 
[Component | Mode Setting] 
to display the [PLC Mode 
Setting] dialog box
(1) Select [Program] for 

operation mode 
(2) Click [Set] 
(3) Click [Close] after 
changing

From the [Display 
Parameter] pull-down menu, 
select [Port1: Serial 
Gateway Settings]

Configure [Port1: Port settings] to [Manual] 
and [Port1: Serial communications mode] to 
[Serial Gateway]. Check other settings as 
well, and change if necessary.

Confirm that settings are correct, then select the 
[Transfer [PC to Unit]] button. Click [OK] in the 
transmission confirmation message dialog box.

Click

Select 
[HOSTLINK1] 
and click [OK] 
button.

(4) Re-upload the network configuration information of CompoWay/F. Perform the step (2) 
from the previous page.

Only the Units for which connection is established are displayed in the [Network Structure] 
window, as shown on the next page.

Click [OK] button in a dialog 
box indicating completion of 
transmission

Perform the step (2) in the 
previous page

Click [OK] in the [Edit 
Parameters] dialog box and 
close the dialog box
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The [Network Structure] window 
shows only the Units for which 
connection is established, and Units 
with incorrect communications 
setting are not displayed.

Check the temperature 
controller that is not 
displayed properly and 
configure it correctly

(5) Check the settings of the temperature controller that is not displayed in the [Network 
Structure] window (baud rate, data length, stop bit, parity, Unit number), configure it correctly, 
then re-upload (Perform step (2) from two pages ago). The [Network Structure] window is 
updated.

Now the correctly configured Unit is 
displayed and you can confirm that 
communications settings are correct.

Perform step (2) from two 
pages ago

(6) Move the cursor on E5CN of communications Unit number #002, then select [Start Special 
Application] > [Start with Setting Inherited].

Right-click on the 
communications Unit 
number #002 icon in the 
[Network Structure] window, 
then select [Start Special 
Application] > [Start with 
Setting Inherited]

(6) Dedicated Support Software CX-Thermo is started with the same model and setting as 
that of the temperature controller.
After parameter settings are finished, download the settings to the E5CN of 
communications Unit number #002.

After parameter settings 
are finished, select 
[Communications] > 
[Download to Device], then 
select either [Download all], 
[Download Changed 
Parameters], or [Download 
Changed from Default]
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Save the system configuration for inspection after delivery.

(1) Connect online to a PLC on a network.
The online connection information window is displayed.

Select
[Serial Port] > [NT Link]

Saving System Configuration (1)Saving System Configuration (1)

All communications Units and ports of 
a connected PLC are automatically 
displayed in the online connection 
information window. From this window, 
connect to each network and save the 
configuration to a project file.

All communications Units and ports of 
a connected PLC are automatically 
displayed in the online connection 
information window. From this window, 
connect to each network and save the 
configuration to a project file.

(2) Send the network Structure of DeviceNet to the personal computer.
Connect to DeviceNet from the online connection information window. After connection 
is established, send the network Structure of DeviceNet to the personal computer.Move the cursor on the 

DeviceNet and right-click

Select 
[Transfer [Network to PC]]

Select [Connect]

(3) Send the network configuration of NT Link to the personal computer.
Select the connection menu on the CPU port, then select upper link port and NT Link.
Next, select the transmission menu on the CPU port.

Select 
[Transfer [Network to PC]]

Select [Connect]

(4) Send the Controller Link network configuration to the personal computer.
Connect to the Controller Link network. After connection is established, send the network 
configuration to the personal computer.

Select 
[Transfer [Network to PC]]

Select [Connect]
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Select [Change 
connection to this PLC]

Select [Save As…]

Saving System Configuration (2)Saving System Configuration (2)

(5) Connect to a PLC on the Controller Link network.
Select a remote PLC on the Controller Link network configuration screen (a PLC without a 
square symbol) to switch the connection destination to the PLC.
Destination PLC communication device configuration is displayed in the online connection 
information window.

A Green frame is displayed on 
the specified remote PLC.

A Green frame is displayed on 
the specified remote PLC.

Select 
[Transfer [Network to PC]]

Select [Connect]

All communications Units and 
ports are also displayed in the 
online connection information 
window.

All communications Units and 
ports are also displayed in the 
online connection information 
window.

(6) Send the DeviceNet network configuration on the remote PLC.
Connect to DeviceNet from the online connection information window and send the 
network configuration to the personal computer.

(7) Send the DeviceNet network configuration on another remote PLC.
Repeat the steps from (6) and (7). After transmission, all the networks sent to the 
workspace are displayed.

(8) Save all the configurations.
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Select [Compare]

Click [Close]

Click [OK]

System Configuration Verification (1)System Configuration Verification (1)

Confirm that the System has the same wiring and settings as before disassembly.
⇒ CX-Integrator verification is complete.

Confirm that the System has the same wiring and settings as before disassembly.
⇒ CX-Integrator verification is complete.

(1) Connect online to a PLC on a network.
The online connection information window is displayed.

All communications Units and ports 
of a connected PLC are 
automatically displayed in the online 
connection information window.

All communications Units and ports 
of a connected PLC are 
automatically displayed in the online 
connection information window.

(2) Verify the DeviceNet network configuration.
Connect to a target DeviceNet from the workspace and verify the network Structure.

(3) Any error found in the configuration verification will be displayed in the verification result 
dialog box.

If you find a Slave that is not on 
the network, you may have 
incorrect wiring in the network.

If you find a Slave that is not on 
the network, you may have 
incorrect wiring in the network.

(4) After solving the error, verify the configuration again.

A message is displayed indicating 
verification matching and now it can 
be confirmed that the configuration is 
the same as that before disassembly.

A message is displayed indicating 
verification matching and now it can 
be confirmed that the configuration is 
the same as that before disassembly.

Select [Connect]
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Select [Connect]

Select [Change 
connection to this PLC]

System Configuration Verification (2)System Configuration Verification (2)

(5) Verify the NT Link network.
Connect to the NT Link from the workspace and verify the network configuration.
Confirm that the same verification matching message is displayed as in step (4).

(6) Verify the Controller Link network.
Connect to DeviceNet from the online connection information window and verify the 
network Structure.
Confirm that the same verification matching message is displayed as in step (4).

(7) Connect to a PLC on the Controller Link network.
Connect to a remote PLC using the same procedure as the step (5) for saving a System 
configuration.
Use steps from (2) to (4) to verify the DeviceNet network.

(8) Verify the DeviceNet configuration on another remote PLC.
Use the same procedure as step (2) for Network “N4” to verify the network Structure.

Select [Compare]

Select [Connect]

Select [Compare]

Select [Connect]

Select [Compare]
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Controller Link DiagnosisController Link Diagnosis

Confirm that the Controller Link connection is correct with an upper level System.
⇒ Diagnosis result check OK

Confirm that the Controller Link connection is correct with an upper level System.
⇒ Diagnosis result check OK

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection 
information window.

(2) Next, select the Controller Link network tool.

Right-click a DeviceNet 
Unit under Target Device 
in the online connection 
information window, then 
select [Connect]
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Right-click a CompoNet
Master Unit under a 
connection target PLC 
in the online connection 
information window, 
then select [Connect]

Checking CompoNet NetworkChecking CompoNet Network

Checking 
CompoNet

Network

On-site 
Network 
Check

(1) Connect to PLC online, then connect to a CompoNet through the online 
connection information window.

Remove CompoNet communications errors and establish communications.
Check the Slave status monitor from Master Unit.

(2) Transfer the CompoNet network configuration to the personal computer.

(3) Select [Master only (including parameters)], then click [Transfer] button.

The Master Unit is displayed in the network configuration window.



Right-click on the 
Master Unit icon and 
select [Monitor] to 
display the device 
monitor screen. Select 
[Status] tab

Checking 
CompoNet

Network

If any unit is missing 
or communication 
errors are detected, 
check the wiring and 
DIP switch settings of 
the applicable units to 
solve the problems.

(6) Repeat the steps (2) and (3) to confirm that the CompoNet network is functioning 
properly.

(4) Monitor a component.

The monitor window is displayed.

(5) Click [Slave Status] tab to check the status of Slave Units.

An error is detected in the 
Slave Units indicated in red.

On-site 
Network 
Check



Right-click on 3G3MV-
PDRT2 and select [Start 
Special Application] 

Setup Drives on DeviceNet and start CX-Drive on CX-Integrator window.
An example of 3G3MV-PDRT2 is shown below.

Starting CX-Drive via DeviceNetStarting CX-Drive via DeviceNet

Select [Start with Setting 
Inherited]

DeviceNet
Connection

RS232C
Connection

Servo/Inverter
Settings

When opening a stored data file after starting the dedicated tool, select [Start 
Only]. If [Start with Setting Inherited] is selected, new data is created.

Select Settings to set
detailed Inverter specifications.

CX-Drive starts and  
Inverter property 
settings are shown

Save data

If more than one drive setting data is edited, drive data is saved by drive type and a total 
overview is saved in a work file.

Click            and save the data.



From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Drive] > [CX-Drive] to 
start CX-Drive when you connect Servo or Inverter with serial connection to your computer. 

Connecting a Servo or Inverter to a Personal Computer Serially.Connecting a Servo or Inverter to a Personal Computer Serially.

Set communication
Specifications

DeviceNet
Connection

RS232C
Connection

Servo/Inverter
Settings

To  execute 
Autodetect, select 
[Settings] and define 
the search conditions

Save data

Select [File] > [New] to create new data if the drive specifications are known.
If the drive is already connected, select [File] > [Autodetect] to detect the model 
and specification of this connected drive.

Select [Settings]

Or, select [File] > [Autodetect] to detect the connected drive specification.

Click             and save the data.



Terms and Conditions of Sale
1. Offer; Acceptance. These terms and conditions (these "Terms") are deemed

part of all quotes, agreements, purchase orders, acknowledgments, price lists,
catalogs, manuals, brochures and other documents, whether electronic or in
writing, relating to the sale of products or services (collectively, the "Products")
by Omron Electronics LLC and its subsidiary companies (“Omron”). Omron
objects to any terms or conditions proposed in Buyer’s purchase order or other
documents which are inconsistent with, or in addition to, these Terms. 

2. Prices; Payment Terms. All prices stated are current, subject to change with-
out notice by Omron. Omron reserves the right to increase or decrease prices
on any unshipped portions of outstanding orders. Payments for Products are
due net 30 days unless otherwise stated in the invoice.

3. Discounts. Cash discounts, if any, will apply only on the net amount of invoices
sent to Buyer after deducting transportation charges, taxes and duties, and will
be allowed only if (i) the invoice is paid according to Omron’s payment terms
and (ii) Buyer has no past due amounts.

4. Interest. Omron, at its option, may charge Buyer 1-1/2% interest per month or
the maximum legal rate, whichever is less, on any balance not paid within the
stated terms.

5. Orders. Omron will accept no order less than $200 net billing. 
6. Governmental Approvals. Buyer shall be responsible for, and shall bear all

costs involved in, obtaining any government approvals required for the impor-
tation or sale of the Products.

7. Taxes. All taxes, duties and other governmental charges (other than general
real property and income taxes), including any interest or penalties thereon,
imposed directly or indirectly on Omron or required to be collected directly or
indirectly by Omron for the manufacture, production, sale, delivery, importa-
tion, consumption or use of the Products sold hereunder (including customs
duties and sales, excise, use, turnover and license taxes) shall be charged to
and remitted by Buyer to Omron.

8. Financial. If the financial position of Buyer at any time becomes unsatisfactory
to Omron, Omron reserves the right to stop shipments or require satisfactory
security or payment in advance. If Buyer fails to make payment or otherwise
comply with these Terms or any related agreement, Omron may (without liabil-
ity and in addition to other remedies) cancel any unshipped portion of Prod-
ucts sold hereunder and stop any Products in transit until Buyer pays all
amounts, including amounts payable hereunder, whether or not then due,
which are owing to it by Buyer. Buyer shall in any event remain liable for all
unpaid accounts.

9. Cancellation; Etc. Orders are not subject to rescheduling or cancellation
unless Buyer indemnifies Omron against all related costs or expenses.

10. Force Majeure. Omron shall not be liable for any delay or failure in delivery
resulting from causes beyond its control, including earthquakes, fires, floods,
strikes or other labor disputes, shortage of labor or materials, accidents to
machinery, acts of sabotage, riots, delay in or lack of transportation or the
requirements of any government authority. 

11. Shipping; Delivery. Unless otherwise expressly agreed in writing by Omron:
a. Shipments shall be by a carrier selected by Omron; Omron will not drop ship

except in “break down” situations.
b. Such carrier shall act as the agent of Buyer and delivery to such carrier shall

constitute delivery to Buyer;
c. All sales and shipments of Products shall be FOB shipping point (unless oth-

erwise stated in writing by Omron), at which point title and risk of loss shall
pass from Omron to Buyer; provided that Omron shall retain a security inter-
est in the Products until the full purchase price is paid;

d. Delivery and shipping dates are estimates only; and
e. Omron will package Products as it deems proper for protection against nor-

mal handling and extra charges apply to special conditions.
12. Claims. Any claim by Buyer against Omron for shortage or damage to the

Products occurring before delivery to the carrier must be presented in writing
to Omron within 30 days of receipt of shipment and include the original trans-
portation bill signed by the carrier noting that the carrier received the Products
from Omron in the condition claimed.

13. Warranties. (a) Exclusive Warranty. Omron’s exclusive warranty is that the
Products will be free from defects in materials and workmanship for a period of
twelve months from the date of sale by Omron (or such other period expressed
in writing by Omron). Omron disclaims all other warranties, express or implied.
(b) Limitations. OMRON MAKES NO WARRANTY OR REPRESENTATION,
EXPRESS OR IMPLIED, ABOUT NON-INFRINGEMENT, MERCHANTABIL-

ITY OR FITNESS FOR A PARTICULAR PURPOSE OF THE PRODUCTS.
BUYER ACKNOWLEDGES THAT IT ALONE HAS DETERMINED THAT THE
PRODUCTS WILL SUITABLY MEET THE REQUIREMENTS OF THEIR
INTENDED USE. Omron further disclaims all warranties and responsibility of
any type for claims or expenses based on infringement by the Products or oth-
erwise of any intellectual property right. (c) Buyer Remedy. Omron’s sole obli-
gation hereunder shall be, at Omron’s election, to (i) replace (in the form
originally shipped with Buyer responsible for labor charges for removal or
replacement thereof) the non-complying Product, (ii) repair the non-complying
Product, or (iii) repay or credit Buyer an amount equal to the purchase price of
the non-complying Product; provided that in no event shall Omron be responsi-
ble for warranty, repair, indemnity or any other claims or expenses regarding
the Products unless Omron’s analysis confirms that the Products were prop-
erly handled, stored, installed and maintained and not subject to contamina-
tion, abuse, misuse or inappropriate modification. Return of any Products by
Buyer must be approved in writing by Omron before shipment. Omron Compa-
nies shall not be liable for the suitability or unsuitability or the results from the
use of Products in combination with any electrical or electronic components,
circuits, system assemblies or any other materials or substances or environ-
ments. Any advice, recommendations or information given orally or in writing,
are not to be construed as an amendment or addition to the above warranty.
See http://www.omron247.com or contact your Omron representative for pub-
lished information.

14. Limitation on Liability; Etc. OMRON COMPANIES SHALL NOT BE LIABLE
FOR SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES,
LOSS OF PROFITS OR PRODUCTION OR COMMERCIAL LOSS IN ANY
WAY CONNECTED WITH THE PRODUCTS, WHETHER SUCH CLAIM IS
BASED IN CONTRACT, WARRANTY, NEGLIGENCE OR STRICT LIABILITY.
Further, in no event shall liability of Omron Companies exceed the individual
price of the Product on which liability is asserted.    

15. Indemnities. Buyer shall indemnify and hold harmless Omron Companies and
their employees from and against all liabilities, losses, claims, costs and
expenses (including attorney's fees and expenses) related to any claim, inves-
tigation, litigation or proceeding (whether or not Omron is a party) which arises
or is alleged to arise from Buyer's acts or omissions under these Terms or in
any way with respect to the Products.   Without limiting the foregoing, Buyer (at
its own expense) shall indemnify and hold harmless Omron and defend or set-
tle any action brought against such Companies to the extent based on a claim
that any Product made to Buyer specifications infringed intellectual property
rights of another party. 

16. Property; Confidentiality. Any intellectual property in the Products is the exclu-
sive property of Omron Companies and Buyer shall not attempt to duplicate it
in any way without the written permission of Omron. Notwithstanding any
charges to Buyer for engineering or tooling, all engineering and tooling shall
remain the exclusive property of Omron. All information and materials supplied
by Omron to Buyer relating to the Products are confidential and proprietary,
and Buyer shall limit distribution thereof to its trusted employees and strictly
prevent disclosure to any third party. 

17. Export Controls. Buyer shall comply with all applicable laws, regulations and
licenses regarding (i) export of products or information; (iii) sale of products to
“forbidden” or other proscribed persons; and (ii) disclosure to non-citizens of
regulated technology or information.    

18. Miscellaneous. (a) Waiver. No failure or delay by Omron in exercising any right
and no course of dealing between Buyer and Omron shall operate as a waiver
of rights by Omron. (b) Assignment. Buyer may not assign its rights hereunder
without Omron's written consent. (c) Law. These Terms are governed by the
law of the jurisdiction of the home office of the Omron company from which
Buyer is purchasing the Products (without regard to conflict of law princi-
ples).   (d) Amendment. These Terms constitute the entire agreement between
Buyer and Omron relating to the Products, and no provision may be changed
or waived unless in writing signed by the parties. (e) Severability. If any provi-
sion hereof is rendered ineffective or invalid, such provision shall not invalidate
any other provision. (f) Setoff. Buyer shall have no right to set off any amounts
against the amount owing in respect of this invoice. (g) Definitions. As used
herein, “including” means “including without limitation”; and “Omron Compa-
nies” (or similar words) mean Omron Corporation and any direct or indirect
subsidiary or affiliate thereof. 

Certain Precautions on Specifications and Use
1. Suitability of Use. Omron Companies shall not be responsible for conformity

with any standards, codes or regulations which apply to the combination of the
Product in the Buyer’s application or use of the Product. At Buyer’s request,
Omron will provide applicable third party certification documents identifying
ratings and limitations of use which apply to the Product. This information by
itself is not sufficient for a complete determination of the suitability of the Prod-
uct in combination with the end product, machine, system, or other application
or use. Buyer shall be solely responsible for determining appropriateness of
the particular Product with respect to Buyer’s application, product or system.
Buyer shall take application responsibility in all cases but the following is a
non-exhaustive list of applications for which particular attention must be given:
(i) Outdoor use, uses involving potential chemical contamination or electrical
interference, or conditions or uses not described in this document.
(ii) Use in consumer products or any use in significant quantities.    
(iii) Energy control systems, combustion systems, railroad systems, aviation
systems, medical equipment, amusement machines, vehicles, safety equip-
ment, and installations subject to separate industry or government regulations. 
(iv) Systems, machines and equipment that could present a risk to life or prop-
erty. Please know and observe all prohibitions of use applicable to this Prod-
uct. 
NEVER USE THE PRODUCT FOR AN APPLICATION INVOLVING SERIOUS
RISK TO LIFE OR PROPERTY OR IN LARGE QUANTITIES WITHOUT
ENSURING THAT THE SYSTEM AS A WHOLE HAS BEEN DESIGNED TO

ADDRESS THE RISKS, AND THAT THE OMRON’S PRODUCT IS PROP-
ERLY RATED AND INSTALLED FOR THE INTENDED USE WITHIN THE
OVERALL EQUIPMENT OR SYSTEM.    

2. Programmable Products. Omron Companies shall not be responsible for the
user’s programming of a programmable Product, or any consequence thereof. 

3. Performance Data. Data presented in Omron Company websites, catalogs
and other materials is provided as a guide for the user in determining suitabil-
ity and does not constitute a warranty. It may represent the result of Omron’s
test conditions, and the user must correlate it to actual application require-
ments. Actual performance is subject to the Omron’s Warranty and Limitations
of Liability. 

4. Change in Specifications. Product specifications and accessories may be
changed at any time based on improvements and other reasons. It is our prac-
tice to change part numbers when published ratings or features are changed,
or when significant construction changes are made. However, some specifica-
tions of the Product may be changed without any notice. When in doubt, spe-
cial part numbers may be assigned to fix or establish key specifications for
your application. Please consult with your Omron’s representative at any time
to confirm actual specifications of purchased Product. 

5. Errors and Omissions. Information presented by Omron Companies has been
checked and is believed to be accurate; however, no responsibility is assumed
for clerical, typographical or proofreading errors or omissions.



                   Note: Specifications are subject to change.                          © 2008 Omron Electronics LLC                                     Printed in U.S.A.
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